Heads-up
Design

Summary

In this chapter, you learn about:
The Startup Dialog
Right-click Galore
DesignCenter

Status Bar

3D Improvements

MDI

The Mouse
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AutoCAD’s seldom used Startup Dialog, introduced in R14,
displays each time you first start AutoCAD. (If it does not,

click Tools » Options, System tab, then check the Show
Sartup dialog check box. Close and restart AutoCAD.)
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The startup dialog offers the following choices:

e Open aDrawing - by choosing from alist of your
last four, or browsing.

e Sart from Scratch - based on your choice of
Metric or English units.

e UseaTemplate - by choosing atemplate as the
basis for a new drawing.

e UseaWizard - set up anew drawing.
Open a Drawing

More often than not, users cancel the startup dialog, then
click the File pull-down menu to choose from their list of
four recent drawings, or use the Open command. Thisisall
available in the startup dialog by clicking the Open button:
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Click on one of the recently used filenames to display a
drawing preview. Click the Browse button to browse alocal
or network drive.

Start from Scratch

In the Startup dialog, click Start from Scratch, then
choose English or Metric units. This begins a new D
empty drawing.

Use a Template

In the Startup dialog, click Use a Template, then choose

from the list of template drawings.

If you highlight one of the DSC templates, you'll notice a
description in the dialog. Click OK to begin a new drawing
based on the selected template. The DSC templates have
pre-configured layers, linetypes and more.
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Create your own templates from your current drawing by
choosing File » Saveas from the pull-down menu.
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In the Save as type list, choose AutoCAD Drawing
Template File.



AutoCAD 2000 includes extensive right-click mouse sup-
port. If you're not sure how to do something in AutoCAD,
try right-clicking, and check the shortcut menu for the
option you need!

Depending on where you right-click in AutoCAD, you will
get different shortcut menus.

As with most things in AutoCAD, right-click behavior can
be configured. Many veteran AutoCAD users prefer the
way right-clicking acted in version 14, which was the same
as pressing Enter on the keyboard. Before you change your
right-click settings to act like AutoCAD 14, give these new
features an open-minded try first!

To change right-click behavior, perform the following steps:

1. Right-click on the command line, choose Options.

2. Click onthe User Preferences tab of the Options
diaog.

3. Click the Right-click Customization button.
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4. After adjusting your settings, click Apply & Close.

The Graphic Screen is the area of AutoCAD where you
draw or edit objects.
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Right-clicking in the graphics screen, without objects select-
ed, brings up a menu similar to the one shown in the above
example. In previous AutoCAD releases, right-clicking in
the graphics screen behaves the same as pressing ENTER on
the keyboard, which repeats the last used command.

The first choice in the pop-up menu repeats the last used
command. Other choices include:

Cut Erase objects and put them in the clipboard.
Copy Copy objects to the clipboard.

Copy with Base Point Copy objects to clipboard,
but ask for insertion point (like the BLOCK com-
mand does).

Paste Copies contents of the clipboard into the
drawing (like inserting a block).

Paste as Block Copies contents of the clipboard
into the drawing as a block rather than individual
objects.

Paste to Original Coordinates Copies contents



of the clipboard in the drawing. Instead of asking
for an insertion point, the objects are placed in the
same coordinates as the copied objects.

Undo, Redo, Pan, Zoom No explanation neces-
sary.

Quick Select New object selection command
(which we'll learn about later.)

Find New command to find and replace text.

Options The options command.

4. While your mouse pointer is Eepest CRAPHLOCK
over the graphics screen, click il
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1. Open Chap02Ex01.dwg, if it's not already open.

Right-clicki ngin the graphics screen with one or more 2. Also open Chap02Ex02.dwg.
objects selected brings up a menu that includes the Erase,

Copy, Move, Scale and Rotate commands T . [ <]

[ s Z0OH

[ET}
[
o s [ sz P

Pordp

Erarm
Hir=
ooy Talaeriimn
]
Apse

D st

Hmch, Slect
Frad
Prapaiesg

Open Chap02Ex01.dwg.

Notice the north arrow over the scale. We'll move
it.
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Select the north arrow by clicking on it with your
left mouse button.
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3. You now have two drawings open,
Chap02Ex01.dwg and Chap02Ex02.dwg. This fea-
ture is called Multiple Document Interface (MDI),
meaning you can open multiple documents simulta-
neously. You'll learn more about MDI in later
exercises, but for now remember that you can
switch between open drawings by using the
Window pull-down menu.

4. Switch to Chap02Ex01.dwg using the Window
pull-down menu.
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5. Switch to Paper Space by clicking the 22x34 Plot
Tab at the bottom of the graphics screen.
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6. Zoom to the area shown above.
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8. Right-click, then select Copy with Base Point.
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9. Pick the center of scale ID “D” as the base (inser-
tion) point - make sure you use the center object

snap.

The building outline objects have been copied to the clip-
board, ready to be inserted into this or another drawing.

10. Click Window & Chap02Ex02.dwg from the pull-
down menu.
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11. Zoom to the area shown above.
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13. Pick the center of Scale ID “B”as the insertion
point - make sure you use the center object snap.

This completes exercise 2. Save and close

Chap02Ex01.dwg and Chap02Ex02.dwg.
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Right-Click In a Dialog Box Our objective in this exercise is to attach Topo.tif
into our current drawing. Since files in
Shortcut menus appear when you right-click in some dialog P:\Incoming older than 40 days are automatically

boxes or in dialog tabs. deleted, we’'ll use the right-click shortcut menus
to move Topo.tif to the same folder as our draw-
ing while at the same time attaching it.

5. Stll inthe Select Image File dialog, navigate to
C:\Tutoria (or the folder of your tutorid files).
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Exercise 3 - Right-click Shortcut in the Open 6. Right-click, choose Paste.

Dialog You' ve just move Topo.tif from P:\Incoming... to the
1. Begin anew, empty drawing by clicking File > C:\Tutorial folder.

New from the pull-down menu, choose Start from o o

Scratch, English settings. 7. Highlight Topo.tif, click Open.

2. Click Insert > Raster Image from the pull-down T |
menu.
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3. Inthe Select Image File dialog, navigate to
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— R‘:‘:m 9. Saveyour current drawing as Chap02Ex03.dwg.
Aerans
HOEEEES In addition to moving files, you can use the

AutoCAD file dialog, to copy, delete, rename and

4. Right-click on Topo.tif, choose Cut. change file properties (instead of switching to
Windows Explorer).
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Command in Progress

When you right-click during a command in progress, a
shortcut menu appears specific to that command. Below are
some examples. Notice the command specific options as
well as Pan and Zoom.

Erés Right-click during the Fillet command.
Carcal
';E*_' Eris Right-click during the Polyline
Ton ol command.
(15
Ean Closs
Haltrachh
Langih
e Eris Right-click during the
- e Circle command.
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On the Toolbar

I'.T'i:.m A shortcut menu that lists toolbars will

Dt appear when you right-click on atoolbar
o button. You can use this shortcut menu to

:m" quickly turn toolbars on or off. Check
Myl | marks indicate toolbars that are currently
w oot Froperiey
Chpect Srap on.
Rafeill
::‘“ Right-clicking on an AutoCAD toolbar but-

:x ton will show the list of toolbars in the

Sckh Ediing AutoCAD menu. Right-clicking on one of
*Zemadlets | the NPS toolbar buttons will show the list

Ez of toolbars in the NPS group.
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On the Status Bar . ‘
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The status bar at the bottom of the AutoCAD window dis-
plays coordinates and buttons that control Snap, Grid, Ortho
etc. Right-clicking on the status bar buttons displays a
shortcut menu with On, Off and Settings options.
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On the Command Line
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A shortcut menu that includes a list of recent commands dis-
plays when you right-click on the command line. Selecting
Options in the shortcut menu displays the Options dialog.

DesignCenter

A new browsing tool, DesignCenter, makes it easy for you
to find and reuse data from any AutoCAD drawing, open or
not. You can access drawing content such as blocks, dim
styles, layers, layouts, linetypes, textstyles and xrefs. You
can drag and drop these objects from any drawing on your
local hard drive, network drive or Internet site. A find fea-

ture lets you search for drawing files and drawing content,
for example layers or xrefs.

DesignCenter can be toggled on/off by pressing CTRL+2, or
by clicking Tools  AutoCAD DesignCenter from the pull-
down menu. Since DesignCenter occupies a healthy portion
of your screen real estate, is usually best to turn it on when
needed and then back off.
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Preview

Description

DesignCenter has its own toolbar as well as four panes -
tree, palette, preview and description.
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By default, DesignCenter docks (locks into the edge) in the
left side of the AutoCAD window.
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You can move DesignCenter by clicking on its top border
(shown below), dragging it to another location, then releas-
ing the mouse button. Press and hold CTRL to prevent
DesignCenter from docking while dragging it.

|

The Tree

138 If the DesignCenter Tree button is depressed, the tree
~ window displays folders and files.
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The Desktop buiton di-s-;-:).lay fold.e-rs and files from local and
network drives in the tree pane.
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Click the Open Drawings button to browse content within
drawings you currently have open.
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The History button displays a list of recently opened draw-
ing files.

Read on to find out what to do with the list of files you see
in the tree pane of the DesignCenter.

The Palette

The Palette displays the contents of whatever you’ ve select-
ed in the tree pane.
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For example, if you browse to adrawing file in the tree
pane, click on the + next to the file, then click on Blocks,
the palette will list blocks in that drawing.
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Preview & Description
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The Preview feature lets you see a small image of the object
you' ve selected in the Palette. The example above shows
the preview of a Jpeg image.
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Below the Preview pane is the Description, which displays
information about the selected file. You use Drawing
Properties to save this information with a drawing file -
Chapter 1, exercise 6 discusses Drawing Properties.

Access Data From Any Drawing, Open or Not

The objects you' re browsing from un-opened drawing files -

blocks, dimstyles, layers, layouts, linetypes, textstyles - are
available for you to insert into any drawing you have open.
The exercises below show how.

Exercise 4 - Use the Palette to open a drawing, and
insert a block from another un-open drawing.

1. If youdon't see the DesignCenter in AutoCAD,
click Tools » DesignCenter. Note: If you have
closed al drawing files, AutoCAD won't display a
Tools pull-down menu. In this case, begin a new,
empty drawing by clicking File > New > Start
from Scratch, then choose Tools » DesignCenter.

2. Inthe Tree pane of DesignCenter, browse to the C:\
Acad2000Tutorial\Exercises\ folder. (C: will be
near the top of the list. Double-click on C:, then
double-click on Acad2000Tutorial, then double-
click on Exercises.)

Note: If you've downloaded the files to complete
this exercise, your actual folder may be different
than C:\Acad2000Tutorial\Exercises\. Use the
location to the exercise drawings on your computer.

x
Ls.-m:j WEENA D W G-

i s

| ALPRIF
|| aDOIEAPe ChagdCE=0IE
| Ll udansl
b4 Exmrcoax -

| KRS %

Litum
jHE ChaplCE-Dd
| | ol i ok I-:
L M Doy
| Wi Temp Fisy
1 palod [P ) »
|| Fasgem iz i
|| PROGRAMT —_—
L1 TEWF ".Fi‘
|1 Todora — j |
| | WKKT ""!'_J

Camt 1D

Palette

ko 4 2] fm e e

Pﬂ o Sre_den_05 Llﬂ -
[ 1]

EL TopaghExciaies |5 heavil)

In the Palette pane, you'll seethefilesin
C:\Acad2000Tutorial\Exercises. See the figure
above.
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Open a draw-
ing file by
dragging it
from the
Palette to the
command
line.

4. Open the drawing for this exercise: Drag and drop
Chap02Ex04.dwg from the Palette onto the
AutoCAD command line (the Command: area at

the bottom).
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5. Now we'll insert a block from a drawing we don’t
have open, into the current drawing. Inthe Tree
pane, locate C:\Acad2000Tutorial\Exercises\
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Insert a block from an un-open drawing by dragging it

from the Palette to any open drawing. You'll be prompt-
ed for an insertion point.

6. Inthe Palette, left-click and hold on Grass, drag it
to the drawing, snap it to the ground line using the
nearest object snap.

This completes exercise 4. Close Chap02Ex04.dwg - no
need to save the changes.

Engiem Right-clicking on a drawing file in
digied 1z F oo .

[ the Palette brings up a shortcut
[——— menu, allowing you to insert,

Etmch 4 ol attach as xref or open the draw-
Lo ing. Using the Insert as Block
Dpen . i option presents the AutoCAD

Insert dialog box, which unlike
dragging a file from the Palette,
gives you a chance to specify
scale and rotation. Try it!

Exercise 5 - Import layers from another drawing
1. Open Chap02Ex05.dwg.

2. If you don't see the DesignCenter in AutoCAD,
click Tools » DesignCenter.

3. Inthe Tree pane of DesignCenter, browse to the
C:\Acad2000Tutorial\Exercises\ folder. (C: will be

near the top of

the list. Double-click on C:, then

double-click on Acad2000Tutorial, then double-
click on Exercises.)

Note: If you' ve downloaded the files to complete
this exercise, your actual folder may be different

MyBlocks.dwg. Click the + next to
MyBlocks.dwg, then click on Blocks. You should
see blocks listed in the Palette.

than C:\Acad2000Tutorial\Exercises\. Use the
location to the exercise drawings on your computer.

In the Tree pane, locate
C:\Acad2000Tutorial\Exercises\



Electrical Prototype.dwg. Click the + next to
Electrical Prototype.dwg, then click on Layers. You
should see layers listed in the Palette (see figure

below).
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Import layers from an un-open drawing by dragging
them from the Palette to any open drawing.

5. Inthe Paette, select al the layersin Electrical-
Prototype.dwg by clicking on the first (top) layer
and while holding down the SHIFT key, selecting
the last (bottom) layer. Holding SHIFT selects
concurrent objects.

6. Again in the Palette, left-click and on any of the
selected layers, and while holding down the left
mouse button, drag the layers to the open drawing
Chap02Ex05.dwg, then release the mouse button.

You've just imported the layers from Electrical Prototype
.dwg into Chap02Ex05.dwg. In exercise 4, we inserted
blocks from another, un-opened drawing file. You can also
import Dimstyles, Layouts, Linetypes and Textstyles using
the same drag-and-drop method.

This completes exercise 5. Close Chap02Ex05.dwg - no
need to save the changes.

1. Open Chap02Ex06.dwg.

2. If you don't see the DesignCenter in AutoCAD,
click Tools » DesignCenter.

3. Inthetree pane of DesignCenter, browse to
C:\Acad2000\Sample\DesignCenter\ folder. (C:
will be near the top of the tree list. Double-click
on C:, double-click on Acad2000, double-click on
Sample, double-click on DesignCenter.)

4. Inthe Tree pane, click on the + beside Home-

SpacePlanner.dwg, then click on Blocks.
A@e"d TEOEHR B e

5 ipramr e B a
+ i Faaieras - L5 deg
Sioamt - Spaea Pl —
— r -
1 Fi
-.' o
i

- D

P ADIOD AP Dy . rae cheey e {20 Chers 1

5. Drag and drop blocks from the Palette into the

floorplan, Chap02Ex06.dwg. Arrange the home as
you seefit!l Below is a completed example.

Using DesignCenter’s find feature, you can search for draw-
ing files using content information, such as a layer, block or
xref name, or summary information.

In exercise 6 of chapter 1, we saved summary information -
title, subject, author, keywords and comments - to a drawing
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file. Now we'll use DesignCenter to search for that drawing
using the author.

1. If youdon't see the DesignCenter in AutoCAD,
click Tools » DesignCenter.

2. Click on the Find button from the DesignCenter

toolbar. “
3. IntheFind dialog, use the follow-
ing settings:
Look for:  Drawings
In: C:\Acad2000Tutorial (use Browse if
you want)

Check Search subfolder

L o | B ] [ U [ - [
R Spmch mubdoldet

4. Enter Helen* in the Search for words box, and
select Author from the In the fields list.

Gemchin bherdl  [Holr

I e ) | Aashen

Lf L=

5. Click Find Now.
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If you all went well, and you entered Helen as the Author in
exercise 6, chapter 1, you should see Chap01Ex06.dwg list-
ed in the list of items found.

6. Right-click on Chap01Ex06.dwg,

then select Open in window, which :f:::;ﬂh
will open Chap01Ex06.dwg in the -
AutoCAD drawing editor. Other e, i Wk

options include Load into Palette, oy
Insert as Block, Attach as Xref.

This completes exercise 6. Close Chap01Ex06.dwg.

We entered Helen* as the name to search for,
since * is a wildcard character, meaning search
for any author that starts with the letters HE L E
N, but we don’t care what comes after that. If you

try the search with Helen (no asterisk), your
search results would be empty, since the author
was actually Helen Waite.

Blocks

If you've ever created a block in adrawing, then tried to
locate that drawing and block at alater time, you might
appreciate this DesignCenter find feature: You can search
across afolder and subfolders for a block name.

Exercise 8 - Locate a Block

1. Click File » New from the AutoCAD pull-down
menu. Select Start from scratch, then OK to begin
a new, empty drawing.

2. If you don't see the DesignCenter in AutoCAD,
click Tools » DesignCenter.

3. Click on the Find button #
DesignCenter toolbar.

from the

4. IntheFind dialog, use the following settings:

Look for:  Drawings and Blocks

In: C:\Acad2000 (use Browseiif you wart)
Check Search subfolders
Search for the name: *pillar*
4. Click Find Now.
1l
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Your search results should list two blocks, both in
Oceanarium.dwg.

5. Right-click on foundation pillar, then tzed = et

click Insert Block. ooy
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6. Complete inserting the foundation pillar in your
drawing.

This completes exercise 8. Close your drawing, discard
changes.

You can create your own drawings with frequent-
ly used blocks, then access those drawings using
Design Center. Be sure to store such drawings

on your M: drive, since your C: drive is not
backed up.

Xref's

DesignCenter’s Find feature can be used to locate drawings
with specific xrefs attached. For example, let’s say you
were going to move a drawing, grcabase.dwg, and you
know thisis an xref base sheet. If you move grcabase.dwg
drawing to another folder, any other drawings that have
grcabase.dwg attached as an xref would lose their link to
grcabase.dwg.

Using DesignCenter, you can find al drawings that have
grcabase.dwg attached as an xref. Once you know these
drawing names, you could move grcabase.dwg, then open
each drawing and redirect the xref to the new path.

The example screen below shows the settings used to find
all drawings under P:\Grca that have an xref attached named
grcabase.dwg.

Look for: Xrefs
In: P\Grca (or other folder of you choice)
Check Search subfolder

Search for the name: grcabase
e,
| forak Sreis” namwd ‘greabass’ i
Lok fmr [l w| W [Pigrs = [
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Favorites

Just like Internet Explorer can save your Favorite locations,
so can AutoCAD’s DesignCenter. The following exercise
shows you how to save a project folder from P: to your
favorites, then access drawings from that folder.

Exercise 9 - DesignCenter Favorites

1. If you don't see the DesignCenter in AutoCAD,
click Tools » DesignCenter.

2. Inthe Tree pane of MNP coEM O 34N

Design-Center, navigate | i =
to afolder location which | - =% L
you would like to save to * il % Sl
your Favorites. S .
P:\Acad\232aa\21\La was =" K N .
used in this example. E;

= ] 'J"'mm-.-_l:- |__!

3. Againinthe Tree pane,
right click on the folder,
then choose Add to Favorites.

Now that we've save P\Acad\232aa\21\La as one
of your favorite folders, let’'s send DesignCenter to
that folder.

4. Click the Favorites button = on the
DesignCenter toolbar.

You should see anicon labeled Lain
the Palette. Since“La’ isnot very

descriptive, let’'s change the name... Fplors
Fied....

5. Right-click on the Laicon, then
choose Organize Favorites.

When you are organizing favorites, you are actually
using Windows Explorer.

6. Right-click on the Laicon, then choose
Rename. Typein a new, more descriptive o
name, but remember you cannot use a colon |'"'1§. -
(:) or adlash (\). | entered “Acad 232aa 21".

7. Press Enter once you’'ve typed in a new name for
you shortcut. Close Windows Explorer and return
to AutoCAD.

8. DesignCenter will still haveit's“old” infor- .|
mation and your icon will till be labeled N 4
“La’. Press F5 to refresh DesignCenter. a

9. Double click on your new icon in the Palette.
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Your DesignCenter should look like this:
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10. Open one of the drawings in P:\Acad\232aa\L a
Drag one of the filenames from the Palette to your
AutoCAD command line, as we learned in an earli-

er exercise.
(B
As an dternative, you can right- e
Crghrcs Fveatse ..

click on any of the filenames,

. . . et Bk
then click Open in Window, Btk a0
which opens that drawing in Copy
AutoCAD. s i Wiredow

This completes exercise 9. Close all drawings, discard
changes.

Status Bar

SMAF GRID ORTHD POLAR DEHAF OTRALCE L'WT |H|:I:E_

The Status Bar at the bottom of your AutoCAD window dis-
plays coordinates (the X, Y, Z position of your mouse) and
buttons. Toggle these buttons on and off by left-clicking
with your mouse. Buttons that appear depressed (pushed in
that is, not sad) are on. If you right-click on a status bar
button, you can select Settings... from the shortcut menu.

Missing from the Status Bar is the TILE button. To switch
between Tiled Model Space and Paper Space in AutoCAD
2000, use the Model/Layout tabs instead:

i 4 ¢ M Lawasill Lsioincd 2

New to the Status Bar is POLAR, OTRACK and LWT.

We'll learn about POLAR and OTRACK in chapter 3 and
LWT in chapter 4.

Status Bar Buttons

SNAP mode makes your cursor move in incre-
ments.

GRID displays dots across the limits of your draw-
ing.

ORTHO works like a T-square - your cursor oper-
ates at 90degree intervals. Other angles can be set
- right-click on ORTHO for settings.

POL AR works like Ortho only smarter, if your
cursor is close to the incremental angle setting
(90degree by default), but allows you to pick arbi-
trary angles too.

OSNAP makes your drawing accurate by snapping
the cursor to object endpoints, intersections etc.
Right-click on OSNAP for settings.

OTRACK stands for Object Snap Tracking, draws
temporary tracking vectors (construction lines). To
track from an osnap point, pause over the point
while in acommand - a tracking vector appears
when you move the cursor.

LWT turns lineweight display on/off. Objects and
layers can have lineweights assigned.

M ODEL /PAPER toggles between Model space and
Paperspace.

3D Improvements

Persistent 3D View

“':Mh Using AutoCAD 2000’s new persistent 3D
Fagans views, no longer do you have to use the
::': Hide or Shade command to check the
.:;,-m v progress of your 3D models. Click View
——— Shade, then select one of the view modes.
] Vi
e If you have araster image attached -
nas beware - If you'rein

N o any view other than 2D
Dacdey : h wireframe, you won't
g G Fectee] 4

Pt et g see your raster image.

Bl dmpl] Wi, Bl OF



In previous releases, if you changed your UCS settings,
those settings effected all viewports. In release 2000, each
viewport can have its own UCS setting - if UCSVP=1. To
change UCSVP, type UCSV P<enter> at the command
prompt. 0 = one UCS setting for entire drawing, 1 = Each
viewport remembers its own UCS setting.

Each viewport can have its own UCS setting, as
shown here (if UCSVP=1). These are Modelspace
viewports - Paperspace viewports behave the same
way.

3DORBIT enables you to manipulate the view of 3D objects
by clicking and dragging your pointing device.

Click the ™ toolbar button to start the 3dorbit command

You can view your entire drawing, or select one or more
objects before starting the command. Viewing the entire

drawing may degrade the video display performance.

The 3D orbit view displays an arcball, which isacircle
divided into four quadrants by smaller circles. When 3DOR-
BIT is active, the target of the view stays stationary and the
cameralocation, or point of view, moves around the target.
The center of the arcball, not the center of the objects you're
viewing, is the target point.

Once you start the 3dorbit command, position your mouse
over the area you want to move, then lef-click and drag your
mouse. Imagine the center of the green circle staying put,
and your mouse being the tip of your finger - you are sliding
the drawing with your mouse (your finger). This command
takes a little getting used to, but once you’ ve mastered it,
you'll likeiit.

Erit
= Right-click during the 3dorbit command to
o= display this shortcut menu. Notice you

— ' can switch to a pan or zoom mode. Reset

el View sets the view back to where you
. were before you started 3dorbit - nice if
::,tl. : you manage to mess up your viewpoint.
L In the Projection flyout you can
ootk select Paralel or Perspective

e view.
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5. Now that we have more than one drawing open,
use the Window pull-down menu to select a partic-
ular drawing or:

AutoCAD 2000 lets you open more than one drawing at a

. . . I . Cascade: Arrange all drawings, over-
time, in the same AutoCAD session. Thisis called Multiple 9 g

ol

_ lapping each other. Vs i oy

Document Interface, or MDI. Of course, you can turn this Tile Horizontally: Arrange all draw- —

feature off - see Tools » Option » System Tab > Single ings with edges touching, one above the 1 e s

drawing compatibility mode. You can also control Single- other. " ;‘;::LT

drawing Compatibility Mode by using the SDI system vari- Tile Vertically: Arrange all drawing

able. Some customization or lisp routines may not be com- with edges touching, one beside the other.

patible with MDI. Arrange Icons: (icons are drawings that are mini-

mized).
6. Press CTRL+Tab to switch between open draw-

1. Closeall drawings, but don’t exit AutoCAD (use ings. If your drawings are overlapping, notice how
File  Close from the menu bar). each active drawing windows come to the top.
From the menu bar, click File » Open. This completes exercise 10. Close all drawings, discard

3. Inthe select file dialog, navigate to changes.

C:\Acad2000\Sample folder.
Selukfls I
Losk i | | etdaFe 0 = O 2 | G|

P This exerciseillustrates how you can use the MATCHPROP
(Match Properties) command to make objects in one draw-
ing inherit the properties from an object in another drawing.

Properties that can be copied include color, layer, linetype,
- linetype scale, lineweight, thickness, plot style, and in some
I cases, dimension, text, and hatch.

1. Open Chap02Ex1la.dwg and Chap02Ex11b.dwg.

2. Arrange your screen as shown below. You can use
Window > Tile Horizontally from the menu bar to

4. Inthe Sdlect File dialog, highlight colorwh.dwg,
Elevation.dwg and Lineweights.dwg, then click
Open. To select more than one file, press and hold

. . arrange the drawings.
CTRL. (Press and hold Shift to select files are are 9 9
concurrent.) = alLlE
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The text in Chap02Ex11b.dwg uses a Stylus font.
Our godl in this exercise is to make the text in
Chap02Ex11a.dwg appear the same.

3. Click the o toolbar button to start the MATCH-
PROP command

4.  When prompted to ‘ Select source object’, click on
the Stylus font text in Chap02Ex11b.dwg.

5. When prompted to ‘ Select destination object’, click
on the text in ChapO2Ex11a.dwg, then press Enter.

Match Properties can be used to make a series of
drawings more consistent, as well as save time.

This completes exercise 11. Close both drawings, discard
changes.

In this exercise, we'll drag objects from one drawing into
another. In exercise two, we learned how to right-click copy
using the clipboard - this drag and drop method is simply
another way to copy object between drawings.

1. Open Chap02Ex12.dwg.
2. Start anew, empty drawing.

3. Arrange your screen to see both drawings, as

shown below.
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4. Click onthe text in Chap02Ex12.dwg to enable
grips (blue boxes at each corner).

5. With your mouse pointer over the text, press and
hold your right mouse button, then drag the text
over the empty drawing.

6. When you release the mouse button, click Copy
Here from the shortcut menu. If you drag quickly
from one drawing to another, you will not be pre-
sented with the shortcut menu - the copy here
option will automatically be used.

The shortcut menu present the following options:

Copy Here: Copies the selected objects at the cur-
rent mouse position. Placement is not exact.

Paste as Block: Copies the selected objects at the
current mouse position, but the new objects are
actually an unnamed block.

Paste at Original Coords: Copies the selected
objects to the same coordinates as in the source
drawing.
Cancel
This completes exercise 12. Close all drawings, discard
changes.

If you open more than one drawing at atime, you can begin
acommand in one drawing, and while that command is still
active, switch to another drawing. When you return to the
first drawing, that command will still be waiting to be com-
pleted. For what it's worth, thisis called concurrent com-
mand execution.

AutoCAD 2000 supports Microsoft IntelliMouse and com-
patible pointing devices with real-time Pan and Zoom fea
tures. Rotating the IntelliMouse wheel performs a real-time
zoom; clicking and dragging the wheel performs areal-time
pan and double clicking the wheel performs a zoom extents
function. With these operations, drawing navigation pro-
ceeds smoothly and transparently - even in the middle of a
command.



If you have atwo button mouse with awheel between-

Zoom inf/out: Rotate mouse wheel forward to
zoom in, backward to zoom out. ZOOMFACTOR
system variable is zoom percentage (default is 10 -
try 25 or higher instead).

Real-time Pan: Press the wheel button and drag
the mouse.

Zoom Extents: Double-click the wheel button.
Object snap menu: Press Shift+right-mouse

If you have a mouse with three buttons-

Real-time Pan: Press the middle button and drag
the mouse.

Zoom Extents. Double-click the middle button.
Object snap menu: Press Shift+right-mouse

To display the Object Snap shortcut menu with the middle
or wheel button (disable the pan and zoom extents), set
MBUTTONPAN system variable to 0.

This completes Chapter 2.



